I can not download the datasets such as BraTS2024-Path-Challenge-TrainingData.zip

Created by david yang david_191108
@david_191108 , Excellent!! Glad you are able to download the datasets now :-)
@vchung Thank you very much! When I update my synapse version to v4.4.0, I use the python program download well.
@david_191108 , I reached out to our synapseclient developer and he suggests upgrading to the latest version of synapseclient (v4.4.0): ```text pip install --upgrade synapseclient ``` After upgrading, try running the Python script again to see if that will resolve the MD5 issues you had previously reported. If not, then please try using the synapse CLI where: * When creating your config file with `synapse config`, can you also try running it with the `--debug` flag so that he can better understand the underlying issue(s)? ```text synapse --debug config ``` * Alternatively, if you are manually creating the `.synapseConfig` file, please save it under `C:\Users\user_name\.synapseConfig` rather than Systems32. Let us know if this helps!
Hi organizationers, I still find help for downloading the syn59808537 (BraTS2024-Path-Challenge-TrainingData.zip) and BraTS-GLI datasets. I have try many methods, such as python program, thunder and so on. But I still can not download them. Can you help me again? Thank you very much!
Hi @david_191108 , Apologies for all the issues! I'll file a bug ticket with the team to look into this, but I have never seen this issue. In the meantime, can you remove your Synapse config and lets try another method. Can you set an environmental variable? ``` export SYNAPSE_AUTH_TOKEN=your_access_token synapse login synapse get -r synNNNNNN ``` I must apologize, as I'm not a windows expert, so I'm unsure what the command is to set a environmental variable. If the environmental variable doesn't work, the last resort would be to do something like this ``` synapse -p your_access_token get -r synNNNNN ```
Hi @thomas.yu I have try not specifying the username, and input the my_personal_access_token, the result are as follows.![the result](https://i.postimg.cc/Kcdfd9DN/20240711093854.jpg)
Hi @david_191108 , Apologies for the inconvenience - thanks for letting us know `synapse login` works. When you do `synapse config`, could you try not specifying a username, and press enter?
Hello @thomas.yu, I delete the existing ~/.synapseConfig file in the following image.![the information about deleting the existing ~/.synapseConfig file](https://i.postimg.cc/ZYjJfbMh/20240711004147.jpg) and When I try **synapse login -p your_personal_access_token_**, It does work. But there are still some troubles when i run **synapse config**, just like ![the information about the exception ](https://i.postimg.cc/ZRT133Zv/20240711004241.jpg)
Hi @david_191108 , Apologies for the trouble that you're having. Please follow these steps below 1. Delete your existing `~/.synapseConfig` file 2. For this step to work, you MUST do step 1. Before running `synapse config`, can you try `synapse login -p your_personal_access_token`. Note: do NOT add double quotes at the front and end of your personal access token. If this step does not work, then please re-generate your personal access token and make sure you've copied the entire string from Synapse. 3. After #2 works, please run `synapse config` and follow the prompts. Note: do NOT add double quotes at the front and end of your personal access token Please let me know if this works.
@vchung I used the synapse config, and still get some troubles.![the information about exception](https://i.postimg.cc/TYj97C8S/20240710100250.jpg)
@david_191108 , Apologies for the troubles. Can you try running this instead: ``` synapse config ``` Follow the prompts and it should create a `.synapseConfig` in the right location.
I have create the .synapseConfig file.![the loction of .synapseConfig file](https://i.postimg.cc/mrZb9T1N/20240710013329.jpg) There are still some problem just like in the following image.![the information about exception]
@david_191108 , The 401 error you received is due to not providing Synapse credentials. To do so, create a `.synapseConfig` file in your home directory and enter the following: ```text [authentication] authtoken=YOUR_PAT ``` where `authtoken` is your Synapse Personal Access Token (PAT). [Generate a new PAT](https://www.synapse.org/PersonalAccessTokens:0) with all token permissions enabled, then copy-paste it into `authtoken`.
I try to use this CLI command(synapse -r get SYN_ID) and get the results just like:[the information of the exception](https://i.postimg.cc/rsKjpWw7/20240710005559.jpg) I also used this CLI command(synapse get syn59808537 --downloadLocation E:/MICCAI_2024/BraTS) but I get the error just like in the following picture.![the information about the errror]
@david_191108 , Rather than Python, can you try the CLI command instead? This may help! 1. Open a terminal 2. Enter the following: ``` synapse -r get SYN_ID ``` where `SYN_ID` is the Synapse ID of the file or folder you would like to download. Note that if you want to download a folder, you must use `-r` in the command, as shown above. Hope this helps!
Thank you @vchung . I used the synapse CLI command just as files = synapseutils.syncFromSynapse(syn, "syn59808537",path). But I still get the exception:synapseclient.core.exceptions.SynapseMd5MismatchError: Downloaded file e:\miccai_2024\brats\brats2024-path-challenge-trainingdata.zip.synapse_download_141354395's md5 84da56c10975c3db78b0260c1d3cf87b does not match expected MD5 of 566be6d7cf9f0bd423ebdc15b0099998 .
Hi @david_191108 , Another participant experienced a [similar issue](https://www.synapse.org/Synapse:syn53708249/discussion/threadId=11040&replyId=32479) as you, which they were able to solve by [using a different computer and network connection](https://www.synapse.org/Synapse:syn53708249/discussion/threadId=11040&replyId=32483). Another solution would be to use the synapse CLI command as mentioned in the above post. Hope that helps!
![the information about the exception]
Thank you for attention, I met new program for this.![the information about exception] The error is: synapseclient.core.exceptions.SynapseMd5MismatchError: Downloaded file e:\miccai_2024\brats\brats2024-ped-challenge-validationdata.zip.synapse_download_143437156's md5 1b08ca53a609c5defdc5525c397b5944 does not match expected MD5 of 5989fa4448b446d9d47f556d682392d5
@david_191108 , Thank you for sharing. I am unable to see the attached screenshot(s), however, a couple of things: * The [pathology training data](syn59808537) is a large file, about 50.18 GB. Is it possible that the download could not be completed due to limited disk space on your machine? * For large files, it may be more efficient to download using the synapseclient CLI rather than the web UI. If your machine has Python available, you can [install synapseclient](https://python-docs.synapse.org/tutorials/installation/) and use the `synapse get` command to download a file from Synapse: ```text synapse get syn59808537 [--downloadLocation /path/to/destination] ``` Before running the command, you will first need to provide your Synapse credentials to synapseclient. To do so, create a `.synapseConfig` file in your home directory and enter the following: ```text [authentication] authtoken=YOUR_PAT ``` where `authtoken` is your Synapse Personal Access Token (PAT). [Generate a new PAT](https://www.synapse.org/PersonalAccessTokens:0) with all token permissions enabled, then copy-paste it into `authtoken`. Hopefully this helps!
![https://ibb.co/xgVNVKC](https://ibb.co/xgVNVKC)
I used the thunder download tools,, it only can help me download a little of datasets
![https://ibb.co/GJ53GN3](https://ibb.co/GJ53GN3)
@david_191108 , Apologies for the troubles. I can see that you are on the 2024 Data Access team, so you should be able to download the challenge data. To best help you, can you let us know what steps you are taking to download?

Can not download the datasets page is loading…